Polygon Network not producing blocks

Incident Report for OnFinality Status Page

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 00:41 UTC

Investigating

The Polygon Mainnet Network has stopped producing blocks, impacting our Polygon RPC services
Posted Jul 30, 2025 - 11:47 UTC
This incident affected: OnFinality Public API Service Endpoints (Polygon API Service).