Bittensor Network not producing blocks

Incident Report for OnFinality Status Page

Resolved

This incident has been resolved.
Posted May 29, 2025 - 08:59 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 29, 2025 - 08:23 UTC

Identified

The Bittensor Network has stopped producing blocks, impacting our Bittensor RPC services and private nodes
Posted May 20, 2025 - 23:27 UTC
This incident affected: OnFinality Public API Service Endpoints (Bittensor Finney API Service).