High Latency in North Virginia region
Incident Report for OnFinality Status Page
Resolved
Our North Virginia region is now operating as normal
Posted Aug 16, 2024 - 03:04 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 14, 2024 - 04:16 UTC
Identified
We are experiencing higher than usual latency in services in our North Virginia region due to heavy unexpected load.

We are working to restore full service
Posted Aug 14, 2024 - 04:15 UTC